Sie sind hier

Fehler bei Verwendung von titlesec

Über Jahre habe ich mich mit diversen Hacks bemüht titlesec mit KOMA-Script-Klassen verwendbar zu halten. Zwar wird diese Kombination schon länger nicht mehr empfohlen und seit einiger Zeit sogar davor gewarnt, trotzdem wollte ich im Interesse der Leute, die noch alte Dokumente mit dieser Kombination haben, zumindest dafür Sorge tragen, dass diese alten Dokumente noch funktionieren. Natürlich ist klar, dass in dieser Kombination diverse Features von KOMA-Script nicht verwendet werden können oder sogar Fehler produzieren. Auch ist nicht garantiert, dass titlesec seine volle Funktionalität entfalten kann.

In der Hoffnung, dass neue Versionen von titlesec diese Hacks nicht mehr benötigen und weil ich nicht wissen kann, ob die Hacks mit neuen Versionen noch funktionieren, ist in den KOMA-Script-Klassen eine Sicherung eingebaut, damit die Hacks nur mit Versionen aktiviert werden, mit denen sie auch getestet sind. Nun ist diesen Monat eine neue Version von titlesec erschienen. Für diese sind die Hacks bisher nicht aktiviert. Also führt schon das einfachste Dokument mit titlesec und scrartcl zu Fehlermeldungen im Inhaltsverzeichnis. Wie erwartet findet man in der log-Datei auch die Information:

Class scrartcl Info: Deactivating the `titlesec` workaround,
(scrartcl)           because package is newer than expected on input line 4.

Obwohl ich das ausdrücklich nicht als Fehler von KOMA-Script betrachte, habe ich natürlich den Hack nun mit der aktuellen Version von titlesec getestet und beschlossen ihn auch für Version 2016/03/15 v2.10.1 frei zu geben. Derzeit benötigt man dafür die Prerelease von KOMA-Script 3.20. Und natürlich warne ich weiterhin vor der Kombination eines nicht auf KOMA-Script-Klassen eingerichteten titlesec mit einer solchen Klasse. Und natürlich kann das Problem jederzeit mit einem Update von titlesec erneut auftreten, wenn dieses Update von titlesec erneut nicht auf KOMA-Script-Klassen eingestellt ist.

forum: 

Inzwischen auch für titlesec 2016/03/21 v2.10.2

Comments for "Fehler bei Verwendung von titlesec" abonnieren