Sie sind hier

Why is scrpage2.sty not found after an update of KOMA-Script?

Bild von Markus Kohm

Since the beginning of 2012 there is the successor scrlayer-scrpage, which is based on the layer package scrlayer, for the package scrpage2.

Since KOMA-Script 3.12 from December 2013 scrpage2 is officially deprecated.

Since KOMA-Script 3.14 from October 2014 there is no support for the use of this package and it has its own (bilingual) manual which explicitly warns against using it. In the KOMA-Script manual and in the German KOMA-Script book only scrlayer-scrpage is documented.

Since KOMA-Script 3.24 from September 2017 the package itself warns against its own use.

With KOMA-Script 3.28 it was announced that KOMA-Script is now complete and in future step by step obsolete things will be removed.

With KOMA-Script 3.30 from April 2020, more than eight years after a successor for scrpage2 has been released, the obsolete scrpage2 is removed from KOMA-Script. On CTAN it is still available in KOMA-Script obsolete. But you have to unpack and install it yourself, because it is marked as deprecated there, too, and TeX distributions are requested not to distribute this package anymore. For this reason, after updating KOMA-Script to version 3.30 the package is usually not found anymore and LaTeX consequently reports an error that the file scrpage2.sty could not be found.

In general I do not recommend (for years) the usage of scrpage2, because this package does not integrate well with KOMA-Script anymore. For example, it does not support the advanced options KOMA-Script offers for the classes and most packages since version 2.95 and thus since 2006. For a first step it is usually sufficient to replace scrpage2 with scrlayer-scrpage when loading the package.

If the loading of scrpage2 is hidden in another package or class, you can also use:

\RequirePackage{scrlfile}
\ReplacePackage{scrpage2}{scrlayer-scrpage}

before loading the class. For more information about this command, please refer to the KOMA-Script manual and the German KOMA-Script book. However, I should point out that classes or packages that still use scrpage2 years after the package was declared obsolete probably have quite other issues and should be considered obsolete themselves. But as we all know, everyone needs to know for himself whether he wants to go down this road or not.

Of course, simply replacing scrpage2 with scrlayer-scrpage is not the ideal solution. scrlayer-scrpage supports all options and commands of scrpage2. However, some of them are also declared deprecated and should therefore be replaced by the current options and commands, which are documented in the KOMA-Script manual and in the German KOMA-Script book. As mentioned above, obsolete things will be removed one by one from future versions of KOMA-Script.

Note: This page has been translated with help of DeepL.

Comments for "Why is scrpage2.sty not found after an update of KOMA-Script?" abonnieren